VeraCrypt
aboutsummaryrefslogtreecommitdiff
path: root/src/Build/CMakeLists.txt
diff options
context:
space:
mode:
authorMounir IDRASSI <mounir.idrassi@idrix.fr>2022-03-22 00:13:52 +0100
committerMounir IDRASSI <mounir.idrassi@idrix.fr>2022-03-22 00:56:54 +0100
commit69a9c6b3943db402a11bf2609c4778ab08628a76 (patch)
tree83c2209da2e7c7d269239bbaaba4e650d26f28fc /src/Build/CMakeLists.txt
parent165df2188e71c419378e4c70c388a7f4d54921b5 (diff)
downloadVeraCrypt-69a9c6b3943db402a11bf2609c4778ab08628a76.tar.gz
VeraCrypt-69a9c6b3943db402a11bf2609c4778ab08628a76.zip
Update release notes for 1.26.0 and set its date to March 21st 2022
Diffstat (limited to 'src/Build/CMakeLists.txt')
-rw-r--r--src/Build/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Build/CMakeLists.txt b/src/Build/CMakeLists.txt
index 51c8bdd2..24c37df9 100644
--- a/src/Build/CMakeLists.txt
+++ b/src/Build/CMakeLists.txt
@@ -1,50 +1,50 @@
# - Minimum CMake version
cmake_minimum_required(VERSION 2.8.0)
# - Obligatory parameters
# -DVERACRYPT_BUILD_DIR : folder that contains 'usr' folder
# -DNOGUI : TRUE if building 'Console' version, 'FALSE' if building 'GUI' version
if ( NOT DEFINED VERACRYPT_BUILD_DIR )
MESSAGE(FATAL_ERROR "VERACRYPT_BUILD_DIR variable MUST BE set to the path of the folder which contains 'usr' folder")
elseif ( NOT DEFINED NOGUI )
MESSAGE(FATAL_ERROR "NOGUI variable MUST BE set to TRUE if building 'Console' version, 'FALSE' otherwise")
endif()
# - Set version of the package
-set( FULL_VERSION "1.25.9" )
-set( VERSION "1.25.9" )
+set( FULL_VERSION "1.26.0" )
+set( VERSION "1.26.0" )
set( RELEASE "1" )
# - Set PROJECT_NAME and CONFLICT_PACKAGE values
if (NOGUI)
set( PROJECT_NAME "veracrypt-console" )
set( CONFLICT_PACKAGE "veracrypt" )
else()
set( PROJECT_NAME "veracrypt" )
set( CONFLICT_PACKAGE "veracrypt-console" )
endif()
project(${PROJECT_NAME})
# - Check whether 'Tcdefs.h' and 'License.txt' exist
if(NOT EXISTS "$ENV{SOURCEPATH}/Common/Tcdefs.h")
MESSAGE(FATAL_ERROR "Tcdefs.h does not exist.")
elseif(NOT EXISTS "$ENV{SOURCEPATH}/License.txt")
MESSAGE(FATAL_ERROR "License.txt does not exist.")
endif()
# - Detect build system bitness
# The following variable will be set
# $SUFFIX 32 64
# $CMAKE_SYSTEM_NAME Windows Linux Darwin
# N.B :
# To build for 32-bit under 64-bit, set 'CMAKE_SIZEOF_VOID_P' to '4'
if( CMAKE_SIZEOF_VOID_P EQUAL 8 )
# Build System is under 64-bit arch
set (SUFFIX "64")
MESSAGE(STATUS "Build System = ${CMAKE_SYSTEM_NAME} - Bitness : 64-bit - Compiler : ${CMAKE_CXX_COMPILER_ID}")
elseif( CMAKE_SIZEOF_VOID_P EQUAL 4 )
# Build System is under 32-bit arch
set (SUFFIX "32")