diff options
Diffstat (limited to 'src/Build/CMakeLists.txt')
-rw-r--r-- | src/Build/CMakeLists.txt | 11 |
1 files changed, 8 insertions, 3 deletions
diff --git a/src/Build/CMakeLists.txt b/src/Build/CMakeLists.txt index 0c602f03..02a8ca2d 100644 --- a/src/Build/CMakeLists.txt +++ b/src/Build/CMakeLists.txt | |||
@@ -243,7 +243,7 @@ if ( ( PLATFORM STREQUAL "Debian" ) OR ( PLATFORM STREQUAL "Ubuntu" ) ) | |||
243 | set( CPACK_DEBIAN_PACKAGE_ARCHITECTURE ${ARCHITECTURE} ) # mandatory | 243 | set( CPACK_DEBIAN_PACKAGE_ARCHITECTURE ${ARCHITECTURE} ) # mandatory |
244 | 244 | ||
245 | if (NOGUI) | 245 | if (NOGUI) |
246 | # We build wxWidgets statically so that we don't depend on any GTK library | 246 | # Link against statically built wxWidgets so that we don't depend on any GTK library |
247 | set( CPACK_DEBIAN_PACKAGE_DEPENDS "libfuse2, dmsetup, sudo" ) | 247 | set( CPACK_DEBIAN_PACKAGE_DEPENDS "libfuse2, dmsetup, sudo" ) |
248 | else () | 248 | else () |
249 | # Link against gtk3 version of wxWidgets if >= Debian 10 or >= Ubuntu 18.04 | 249 | # Link against gtk3 version of wxWidgets if >= Debian 10 or >= Ubuntu 18.04 |
@@ -254,8 +254,13 @@ if ( ( PLATFORM STREQUAL "Debian" ) OR ( PLATFORM STREQUAL "Ubuntu" ) ) | |||
254 | set( CPACK_DEBIAN_PACKAGE_DEPENDS "libwxgtk3.0-gtk3-0v5, libfuse2, dmsetup, sudo" ) | 254 | set( CPACK_DEBIAN_PACKAGE_DEPENDS "libwxgtk3.0-gtk3-0v5, libfuse2, dmsetup, sudo" ) |
255 | 255 | ||
256 | else () | 256 | else () |
257 | 257 | # Link against statically built wxWidgets on Ubuntu 14.04 and older, and Debian 8 and older | |
258 | set( CPACK_DEBIAN_PACKAGE_DEPENDS "libwxgtk3.0-0v5, libfuse2, dmsetup, sudo" ) | 258 | if ( ( ( PLATFORM STREQUAL "Debian" ) AND ( PLATFORM_VERSION VERSION_LESS_EQUAL "8" ) ) |
259 | OR ( ( PLATFORM STREQUAL "Ubuntu" ) AND ( PLATFORM_VERSION VERSION_LESS_EQUAL "14.04" ) ) ) | ||
260 | set( CPACK_DEBIAN_PACKAGE_DEPENDS "libgtk2.0-0, libfuse2, dmsetup, sudo" ) | ||
261 | else () | ||
262 | set( CPACK_DEBIAN_PACKAGE_DEPENDS "libwxgtk3.0-0v5, libfuse2, dmsetup, sudo" ) | ||
263 | endif () | ||
259 | 264 | ||
260 | endif() | 265 | endif() |
261 | endif() | 266 | endif() |